Modals

Modal width size not working on mobile

3 months 4 weeks ago #78322

Bonnie Unsworth's Avatar Bonnie Unsworth

imagineit-more.com/home-inspections/services
The numbers on the right are modals. They are sized for 400 px wide and look fine on desk top but they go very wide on smart phone. Do you have a suggestion for a fix?

3 months 4 weeks ago #78323

Peter van Westen's Avatar Peter van Westen Admin

Looks like you are getting a javascript error.
Can you give me (super) admin and (s)ftp access so I can take a look?
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

3 months 4 weeks ago #78345

Bonnie Unsworth's Avatar Bonnie Unsworth

Confidential information:
(hidden)

Much appreciated

3 months 3 weeks ago #78389

Peter van Westen's Avatar Peter van Westen Admin

It looks fine here on narrow screen after I force reload the page.
Have you seen the issue on an actual mobile screen? Or are you testing this on the desktop by making the browser narrow?

3 months 3 weeks ago #78393

Bonnie Unsworth's Avatar Bonnie Unsworth

I test on iPhone 6, iPad & my client has an android.

3 months 3 weeks ago #78394

Peter van Westen's Avatar Peter van Westen Admin

Looks like a conflict with scripts loaded by your template.
Can you reproduce the issue when using the Joomla core template protostar?

3 months 3 weeks ago #78395

Bonnie Unsworth's Avatar Bonnie Unsworth

I'll try that tomorrow and get back.

3 months 3 weeks ago #78427

Bonnie Unsworth's Avatar Bonnie Unsworth

I set the page to protostar default and the modals module doesn't even appear.
I'm using modals on another site under construction - bunsworth.com/security-systems/
The icons on the right are models and the first 4 do size on mobile to a narrow width the rest don't.
Thanks for your help.

3 months 3 weeks ago #78431

Peter van Westen's Avatar Peter van Westen Admin

I don't see any modal links on that site.
If some work, and some don't. Then it must be due to the content loaded inside the modal that is forcing it to load too large.

Try opening the modal in iframe mode:

{modal url="your/url" iframe="true"}
Or switch on the option in Modals plugin settings to open links in iframe mode by default.

If you lose the templates styling when opening the modal via the iframe mode, see:
www.regularlabs.com/extensions/modals#th...-the-correct-styling

3 months 3 weeks ago #78441

Bonnie Unsworth's Avatar Bonnie Unsworth

Thanks so much. I'm sure one of these solutions will work.