GeoIp

Not maching countries

2 years 1 day ago #70189

Sukinoz's Avatar Sukinoz

Hello,

We use Geoip in Advanced Module Manager Pro in order to show a module only for visitors from Mexico and United States.

1. we have very very few clics in this link: 5 clics of 81.865 in the last month, and only in two puntual days...

This made us think about if its really showing it or not the module (we live in Spain, so we cant test it)

2. But now, navigating with this IP

Confidential information:
(hidden)
(wich is cleary from Spain ), the module is shown for us!

We understand that Geolocating is not always 100% accurate...
We cant know if the module is been shown in Mexico correctly...
But i think in the second case, the IP is cleary from spain (as seen in myip.es/ and www.iplocation.net/find-ip-address ), even the city is correct, and the module should not be showed.

2 years 1 day ago #70191

Peter van Westen's Avatar Peter van Westen Admin

What combination of assignments do you have in that module?
Do you have the Page Cache plugin switched on?

2 years 1 day ago #70214

Sukinoz's Avatar Sukinoz

Hello Peter,

Thanks for replaying.

What combination of assignments do you have in that module?


INCLUDE in some menu elements and INCLUDE in MEXICO AND UNITED STATES

Do you have the Page Cache plugin switched on?

No, System - Page Cache OFF
But System - Regular Labs - Cache Cleaner ON
And System - jWECache plugin ON (A cache system at server level based on Varnish acelerator)

2 years 1 day ago #70215

Peter van Westen's Avatar Peter van Westen Admin

Is the matching method set to ALL or ANY?

See if switching off the caching makes a difference. That caching plugin might be caching the entire page so that assignments don't have an effect on the modules anymore.

2 years 1 day ago #70221

Sukinoz's Avatar Sukinoz

Matching method is set to ALL

Now i am at home for the weekend, so till Monday can not test it.

In our houses nobody see the module (we are all in Spain), but when we are with the IP a told you before, we see the module.

2 years 1 day ago #70225

Peter van Westen's Avatar Peter van Westen Admin

Can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

2 years 1 day ago #70244

Sukinoz's Avatar Sukinoz

I have prepared a document:

Confidential information:
(hidden)

2 years 1 day ago #70245

Peter van Westen's Avatar Peter van Westen Admin

The ftp login does not work.
And the administrator is protected, so I cannot get to the admin login screen.

2 years 20 hours ago #70251

Sukinoz's Avatar Sukinoz

administrator desproteted.

ftp dont know... it should work,,, i have create the user again..

PD: if you want we can wait till monday and test if the cache is

the problem

2 years 19 hours ago #70253

Peter van Westen's Avatar Peter van Westen Admin

The whole website seems unreachable now.
Frontend doesn't load either.

Admin url: This site can’t be reached
FTP: "Response: La conexion a este servidor ha sido bloqueada en el firewall."

2 years 11 hours ago #70265

Sukinoz's Avatar Sukinoz

I didnt know that the hosting has a protecction access to administration and ftp from non spanish countries

i have add Netherland to the white list of countries.

try now

2 years 9 hours ago #70266

Peter van Westen's Avatar Peter van Westen Admin

Hmmm, I can't reproduce the issue. Even when forcing the IP address to the one you gave in the code that checks the Geo location.
So I suspect it has more to do with caching...