Extension Manager

Bug with analytics ?

1 year 11 months ago #72568

francois's Avatar francois

Hi Peter,

Google analytics doesn't count the visitors on my homepage only since the 23rd of may but it's still visited by loads of people for sure.
I figure what I could have done to cause this issue.
I know on that day I updated my regularlabs extensions :
The extension manager - Modules anywhere - Advanced module manager - Sourcerer - Cache Cleaner
Do you think such issue might have been caused by the update ?

I also updated other extensions on that day :
JCH optimize - Jquery Easy - OSembed

Any idea ?

1 year 11 months ago #72572

Peter van Westen's Avatar Peter van Westen Admin

Check to see if you have any javascript errors on your homepage and check that the google script is placed and loaded correctly on that page (check the html output).

1 year 11 months ago #72580

francois's Avatar francois

I just remembered I had this issue before. It's comes from JCH Analytics don't work well with the combining and minifing tool of JCH. The update of JCH on the 23rd of may is probably in cause and regular lab has certainly nothing to do with all that. Thanks for your help Peter.

1 year 11 months ago #72583

Schmakowski, Boris's Avatar Schmakowski, Boris

Hi francois,

I am also using JCH - there is an other update to 5.1.2, released 14 June 2017 19:00.
While using the free version, I experienced it's better not to use the maximum of 'combining and minifing'.
Automatic Settings - Intermediate
HTML minification level - Advanced
are doing a good job;

Also in combination with Regular Labs tools from Peter, I am running several stable projects with propper code and no errors.

Best, Boris

1 year 11 months ago #72587

francois's Avatar francois

Hi Boris,

You are right if I don't use the maximum level of settings in jch or don't use JCH at all I would not get anymore issues.
The thing is if I do that the "Google speed test" notation is much worse. Unfortunatly it is important for the SEO. That's why I really want my site to work with the maximum level as it should. And as it's worked like this before I know it can. It s just a matter of understanding how to set things right which is always very difficult

1 year 11 months ago #72598

Peter van Westen's Avatar Peter van Westen Admin

Maybe the developers of JCH can be of more help...

1 year 11 months ago #72634

francois's Avatar francois

Yes sure Peter and your forum is not the place to discuss this

1 year 11 months ago #73076

Patrick Jackson's Avatar Patrick Jackson

All,

Having just had the same issue with a few sites after deploying JCH Optimize, and using ReReplacer to deploy my Google Analytics on my site, I've just found the solution that might be helpful to you all, and it's likely others.

This will work for both Google Analytics and Google Tag Manager scripts, as well as any other inline javascript that stops functioning.

Google Analytics code is an inline javascript, and depending on your JCH Optimize automatic settings being used, anything higher than Average (Pro version only) will strip the inline javascript off into a compressed file to optimise the site ( see documentation ).

On the Exclude Options tab in JCH Optimize Pro, click the box to select the function for your anaytics from the list JCH Optimize has identified (you may need to go see what that looks like before you turn JCH Optimize on). Add the item, and save the plugin to save the change.



You can also set the value for "Exclude all internal SCRIPT declarations" to yes, to blank exclude any javascript on the page being compressed.



Patrick