Email Protector

Email Protector 4.1.5 breaks some pages

1 year 11 months ago #71715

Peter van Westen's Avatar Peter van Westen Admin

The issue is caused by something in the JEvents Latest module itself. I have tried to track down where it is doing some weird replacement, but - in all honesty - the code is pretty much spaghetti and is a pain to search through. After an hour of trying to track things down, I have given up. I'll advise you to ask JEvents for further help on this.
If they cannot help you, it pretty much means you cannot use Email Protector together with these JEvents modules.


PS: You still have old and outdated NoNumber extensions installed. You should update these to the latest Regular Labs versions.

1 year 11 months ago #71717

Jim Brooking's Avatar Jim Brooking

Thanks for all the time you put into this.

Can you tell me how to "turn off" email protector for a single page?

1 year 11 months ago #71718

Jim Brooking's Avatar Jim Brooking

Interestingly, I recalled your comment that emails in a form were not protected, so enclosed the entire page source in a <form>...</form> tag. This caused the error messages to go away, at least in Better Preview, but the emails still appear to be protected, and are not displayed on the page. The error messages do, however, appear when the page is displayed outside the editor.

1 year 11 months ago #71731

Peter van Westen's Avatar Peter van Westen Admin

You can disable Email Protector on pages by adding { emailprotector=off } somewhere (without the spaces).

1 year 11 months ago #71736

Jim Brooking's Avatar Jim Brooking

{ emailprotector=off } doesn't seem to change anything. I knew about that function with the Joomla Email Cloaking plugin, but it seems to have no effect on your plugin no matter how I try to insert it..

1 year 11 months ago #71738

Peter van Westen's Avatar Peter van Westen Admin

That is because of the way you are pulling in the content, via modules.
The plugins are run over every module before being passed on to the html.
This means you would need to place that emailprotector=off tag in every single module that generates an email address (that you are placing through "modules in Articles".

1 year 11 months ago #71748

Jim Brooking's Avatar Jim Brooking

I did that in one of the modules and it behaved the same - didn't show the email and threw an error. And also displayed "{emailprotector=off}" in the module.

I turned off the RegularLabs email protector and turned on the one that comes with Joomla and the page dev.fearringtonfha.org/index.php?option=...view=article&id=4694 displays perfectly, so I am going to leave it that way and stop bothering you about Email Protector.

However you should know that even without Email Protector the Components Anywhere update still disables the tabs on my site ( dev.fearringtonfha.org ) because apparently jQuery is un-defined somehow when 4.1.9 is installed, although not when 4.18 is installed. I reported this earlier in the Components Anywhere forum board.

1 year 11 months ago #71749

Peter van Westen's Avatar Peter van Westen Admin

Ok.

Also try playing around with the system plugin ordering.