Email Protector

AcyMailing view in Browser

1 year 1 month ago #70985

Dave Bishop's Avatar Dave Bishop

Hello, I just noticed that if I use a mailto link with the email address as the link text it does not show the email address. I look at the code of the page and I see the cloak code. If I make the link something other than the email e.g. Email Us it works.

This is in the AcyMailing preview in browser option of the newsletter a user receives. Joomla and plugin are up to date.

Missing

Confidential information:
(hidden)


Working
Confidential information:
(hidden)

1 year 1 month ago #70986

Dave Bishop's Avatar Dave Bishop

I can use a email address on the site with no issue. It's only in this AcyMailing preview that it does not work.

1 year 1 month ago #70989

Peter van Westen's Avatar Peter van Westen Admin

Email Protector needs javascripts to work.
You can't use it inside emails.

1 year 1 month ago #70992

Dave Bishop's Avatar Dave Bishop

This is not in an email. Maybe I was not clear about this.

AcyMailing has a "LINK" in an email. The link takes them to a website page where the email address is not showing. Did you see the link I provided in the hidden text?

Thank you

1 year 1 month ago #71003

Peter van Westen's Avatar Peter van Westen Admin

Please try the latest development version from:
www.regularlabs.com/development-releases

1 year 1 month ago #71100

Peter van Westen's Avatar Peter van Westen Admin

Please let me know if the new dev version fixes the issue for you.
If not, Can you give me (s)ftp access so I can take a deeper look?

1 year 1 month ago #71114

Dave Bishop's Avatar Dave Bishop

Hi Peter, I installed the dev version and no change.

Confidential information:
(hidden)

1 year 1 month ago #71115

Peter van Westen's Avatar Peter van Westen Admin

AcyMailing seems to place the content in some weird iframe structure.
This means that any styling and scripts loaded on the page do not affect the content inside the iframe.
Sorry, I cannot help you with this. This is something Acymailing should solve.
Otherwise it pretty much means that you can not use Email Protector with these AcyMailing previews.

1 year 1 month ago #71117

Dave Bishop's Avatar Dave Bishop

I don't understand how a it works if you use it in a link then? If you use any text besides the email address and make it a mailto it works just fine. So that seems odd. Here is the last one I sent and I changed it to "please email us" to get around this.

Confidential information:
(hidden)

1 year 1 month ago #71118

Dave Bishop's Avatar Dave Bishop

I inspected the code of this page an the email protector seems to be functioning normally.

1 year 1 month ago #71121

Peter van Westen's Avatar Peter van Westen Admin

There is no css necessary on that page to deal with displaying the email address.

1 year 1 month ago #71123

Dave Bishop's Avatar Dave Bishop

I see, I'll contact them.

Thank you for your help.

Dave