Sourcerer

Sourcerer hangs when trying to edit code in a an article

3 months 2 weeks ago #91278

Claudio's Avatar Claudio

Hi
If I try to edit an article containing php code the sourcerer pop-ups start but loops forever
The same happens if I create a new article and try to insert some code in there.
I tried to reinstall the plugin but no effect

3 months 2 weeks ago #91280

Peter van Westen's Avatar Peter van Westen Admin

Please try the latest development version from:
www.regularlabs.com/development-releases

3 months 2 weeks ago #91282

Claudio's Avatar Claudio

Ok...
Now it doesn't hang anymore but when I edit an article that contains php code the code does not show in the pop-up editor.

In addition to that if I create a new article and insert the following code

<?php
$mainframe = JFactory::getApplication();
$db = JFactory::getDBO();
$user = JFactory::getUser();
// controlla convenzione
$uid = $user>id;$db>setQuery("SELECT value FROM j25_ajaxregister_field_values WHERE user_id = ".$uid." AND field_id = 40;");
$value = $db>loadResult();
if (empty($value))
$mainframe>redirect('datifatturazione2018');
$mainframe>redirect('verificapreacquisto');?>

After saving the article appears like that

{source}<span style="font-family: courier new, courier, monospace;">&lt;?php<br>$mainframe = JFactory::getApplication();<br>$db = JFactory::getDBO();<br>$user = JFactory::getUser();<br>// controlla convenzione<br>$uid = $user&gt;id;$db&gt;setQuery("SELECT value FROM j25_ajaxregister_field_values WHERE user_id = ".$uid." AND field_id = 40;");<br>$value = $db&gt;loadResult();<br>if (empty($value))<br>$mainframe&gt;redirect('datifatturazione2018');<br>$mainframe&gt;redirect('verificapreacquisto');?&gt;</span>{/source}

My profile is set to "no editor" and I also have SP Page Builder installed

3 months 2 weeks ago #91283

Peter van Westen's Avatar Peter van Westen Admin

3 months 2 weeks ago #91286

Claudio's Avatar Claudio

Thank you very much.
Activating an editor on my profile the problem is solved.
Have a nice day.