ReReplacer

Publishing Assignment options - unexpected behaviour for desktop/mobile

1 year 7 months ago #76177

Silke Menne's Avatar Silke Menne

Hello Peter,

with your help I created a regular expression to replace the 3rd paragraph in articles. Thank you so much!

I bought the PRO version in order to assign a replacement to =>only mobile devices<=.

I don't know what I did wrong, but the problem only appears, when I use the assignment options to exclude the desktop device category - or other way round, when I include mobile devices.
Other assignments, e.g. excluding menu items or single articles, work just fine.

The unexpected behaviour is:
In some articles the replacement shows up on desktop AND on mobile device (Chrome, Firefox; iPhone).
In some articles it does not show up at all, neither on desktop nor on mobile.

I run on Joomla 3.7.4.. It is set to normal caching (30 min.).
In the plugins list, the system plugin Advanced Module Manager is the first, and ReReplacer second.
I also cleared cache of course.

When I wait for some time, then there is no replacement at all. After activating/saving the replacement it is visible again for a while and then disapears again.

Hoping for your help 🙂

Thanks

Silke

1 year 7 months ago #76178

Peter van Westen's Avatar Peter van Westen Admin

You probably have the Page Cache system plugin enabled. That caches the entire page including all modules.
You don't want that plugin enabled.

Read for more on caching here: www.joomlabeginner.com/blog/tutorials/81...able-cache-in-joomla

PS: I can not offer support on outdated Joomla setups. You should update!

1 year 6 months ago #76202

Silke Menne's Avatar Silke Menne

Hi Peter,

I updated to 3.8.2. and checked page cache plugin. It was already disabled.

My settings are conservative caching (30 min.), no platform specific cache, alternative PHP Cache (APC)

Unfortunately the problem did not resolve.

I would be happy if you had another suggestion.

Thanks for your help

Silke

1 year 6 months ago #76205

Peter van Westen's Avatar Peter van Westen Admin

This can probably be fixed by setting the Search Area setting to 'Body'.
But that will probably mean you need to tweak the Search or use the Search Between fields to prevent the replacement from being done inside modules.

If you can't get it to work, can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button to hide the confidential information.

1 year 6 months ago #76409

Silke Menne's Avatar Silke Menne

Hi Peter,

sorry for my late reply. Setting the search area to "Body" helped!

I will do some further tests on different pages, and if I need help, I will get back to you.

Thank you so much and kind regards

Silke