Regular Labs Library

Extension 'System - Regular Labs Library' causes error 502 on multiple sites

6 months 2 days ago #91334

GJ-R Webdevelopment B.V.'s Avatar GJ-R Webdevelopment B.V.

The extension 'System' - Regular Labs Library' causes a 502 error when trying to edit articles, this happens on multiple sites with regular labs extensions, and the error seems to go away when disabling the regular labs library...

The Joomla! version on the sites are all up-to-date.

6 months 2 days ago #91335

Peter van Westen's Avatar Peter van Westen Admin

Can you ask your host (or check your error logs) to see what exactly is causing this?

5 months 4 weeks ago #91362

GJ-R Webdevelopment B.V.'s Avatar GJ-R Webdevelopment B.V.

Already checked out the server logs,

Here's a little snippet.

[Wed Mar 25 08:18:54.342407 2020] [proxy_fcgi:error] [pid 15965] (70007)The timeout specified has expired: [client

Confidential information:
(hidden)
:5319] AH01075: Error dispatching request to :, referer: *siteURL*
[Wed Mar 25 08:19:10.588032 2020] [proxy_fcgi:error] [pid 18902] (70007)The timeout specified has expired: [client
Confidential information:
(hidden)
:9344] AH01075: Error dispatching request to :, referer: *siteURL*
[Wed Mar 25 08:19:24.274348 2020] [proxy_fcgi:error] [pid 18898] (70007)The timeout specified has expired: [client
Confidential information:
(hidden)
:16470] AH01075: Error dispatching request to :, referer: *siteURL*
[Wed Mar 25 08:19:34.773356 2020] [proxy_fcgi:error] [pid 19205] (70007)The timeout specified has expired: [client
Confidential information:
(hidden)
57293] AH01075: Error dispatching request to :, referer: *siteURL*
[Wed Mar 25 08:19:53.748390 2020] [proxy_fcgi:error] [pid 18018] (70007)The timeout specified has expired: [client
Confidential information:
(hidden)
:23107] AH01075: Error dispatching request to :, referer: *siteURL*
[Wed Mar 25 08:24:03.724621 2020] [proxy_fcgi:error] [pid 18601] (70007)The timeout specified has expired: [client
Confidential information:
(hidden)
:26708] AH01075: Error dispatching request to :, referer: *siteURL*

This error only shows when the regular labs library is enabled, i also checked if it's conflicting with any other extension but that's not the case.

5 months 4 weeks ago #91363

Peter van Westen's Avatar Peter van Westen Admin

Yeah, that doesn't help me much.

I recommend you ask your host what exactly is causing this. So what code...

3 months 2 weeks ago #92424

GJ-R Webdevelopment B.V.'s Avatar GJ-R Webdevelopment B.V.

Hi Peter,

After some digging into the code, i finally found the code which causes the error,

On an installed Joomla 3.x site, go to libraries/regularlabs/src/ArrayHelper.php

On line 194-200 you'll find the foreach function which is causing the error on multiple sites.

foreach ($array as &$value)
  {
     if ( ! is_string($value))
      {
        continue;
      }
      $value = trim($value);
  }

3 months 2 weeks ago #92425

Peter van Westen's Avatar Peter van Westen Admin

That code alone doesn't explain why the error would happen.

If you can reproduce this on an online environment to which I can get access, I am happy to look into this.