Modals

*Solved* External URLs opening in same window. Possible conflict with Helix 2.4 or template

9 months 4 weeks ago #77993

Danielle Seiley's Avatar Danielle Seiley

Before I get started here are the specs I'm working with.

I used a clean install of J!3.4.8 which was updated to J!3.6.5 last month.
I'm using Advanced Module Manager Pro 7.0.6 will update to the next version when it's released later this week. (I do my best to stay on top of these things)
I'm using Modals 9.7.1 Free
I'm using the Helix 3 Framework: 2.4

So I thought I was doing everything correctly, but for some reason whenever I click on the link the site opens in the same window leaving my site and going to the site that should have opened up in the lightbox/popup.

I have messed around with the settings and nothing has made this plugin work correctly.
I even disabled every extension except for my template & framework and it still wouldn't work correctly.

After taking a break for a few hours I decided to change my default template to protostar.
I had to wait a few minutes and do about a half a dozen refreshes but when the site appeared using the protostar template I went to the page I have the link on.
I clicked the link and it WORKED!!!!

So I was wondering if you could take a look at my site and see if you can figure out what the problem is that I need to fix or send to the template devs so I can get this fixed. This fix is extremely important, because without it, I will be forced to pull an entire section of my site + it will delay me from opening the site to the public.

Thanks for your time and any help you can give me,
Danielle

Confidential information:
(hidden)

9 months 4 weeks ago #77998

Peter van Westen's Avatar Peter van Westen Admin

Your template is probably loading conflicting jQuery scripts.
It is hard to tell, as your template is caching and combining the scripts. So you can't see what is actually being loaded.

Also, I cannot give any support on outdated setups, like the big red message in this forum states:

Note! Before asking support on Regular Labs extensions, make sure you are using the latest version and your Joomla setup is uptodate!

9 months 4 weeks ago #78000

Danielle Seiley's Avatar Danielle Seiley

If you were to guess, my template is what's causing the problem?

I will go to the template devs and try and talk to them. I'm not entirely sure what to say.

I plan on updating the site and stuff, I just need to get everything working first and that's taking a lot longer than expected.
It's just that I have one piece of software that I don't have the latest release for and it's why I haven't updated the Joomla beyond 3.6.5

9 months 4 weeks ago #78003

Danielle Seiley's Avatar Danielle Seiley

I am one person who HATES to give up on things even if it takes days to figure out. I'm also a programming idiot, I don't know how to do css, javascript, php, etc... The last time I wrote anything was html for 4.x... Now I've got to relearn everything since html 5 is no where near as feature rich as html 4 since html 5 relies so heavily on css now.

I created a support post with my template developers, but that has not stopped me on trying to figure out what the problem is.
I finally found this: www.joomshaper.com/forums/more-problems-with-helix

While the potential solution did not work for the original poster, I did go into my template's advanced settings and turned off: Compress Javascripts.

Refreshed my site and it worked!!! 😁

I had no doubt that your extension worked, but one has the tendency to become quite frustrated after spending nearly 12 hours working on something that won't work. I don't want to leave the compress javascripts setting turned off, but if I turn it back on your extension stops working. I doubt that's your area of expertise though and more of something I'm going to have to talk to my template developers about.

Once we figure it out, I'll come back and let you know what was changed. Until then I might recommend you let others know that if they are using to helix framework that they might wanna turn off the javascript compression feature, or they might have problems like I did.

Sorry for rambling. Thanks and have a good day,
Danielle

9 months 4 weeks ago #78006

Peter van Westen's Avatar Peter van Westen Admin

If you are going to use an extensive template framework like Helix, then conflicts with other extensions is pretty much part of the deal.

9 months 4 weeks ago #78012

Danielle Seiley's Avatar Danielle Seiley

I heard back from my template's developers. I'm not sure what exactly you call the error that causing the conflict, but they told me that I had to turn off Media Versioning in your extension. Once I did that I was told to clear my cache and then I could re-enable javascript compression. This one the one feature I did not mess with when setting up your extension. Needless to say I'm very happy to say that this turned out to be a very easy fix, even though it was "hidden beneath our noses".

So I'm going to go out on a limb and say for those like myself that read over 30 of the 72 pages of the support forum before finally posting, if you have helix and you are having this issue, make sure you turn off Media Versioning. I know that while this works for me, it might not work for everyone, but it's at least worth a try. I have included a picture for reference.

Thanks for letting me post this info here. I really appreciate it.
i.imgur.com/eaDlTKw.png

Danielle

9 months 3 weeks ago #78022

Peter van Westen's Avatar Peter van Westen Admin

Thanks for the feedback.