Email Protector

shortcodes visible / page broken with plugin enabled

1 year 4 months ago #71219

Shawn Scanlan's Avatar Shawn Scanlan

Hi Peter,

A section of a page on my site is shown below:



When Email Protector is enabled, some (not all) RokCandy shortcodes are visible on the front end and are not processed as shortcodes, thus those pages are broken.



Not sure if this is at all relevant, but I have seen this 'visible shortcodes issue' before when attempting to switch over to PHP7.x.
I had to switch back to PHP5.6, as there is no fix available from RocketThemes.

In any case, disabling the plugin solves the problem and I'd love to use it!

Any thoughts?

Thanks!
-Shawn

1 year 4 months ago #71222

Peter van Westen's Avatar Peter van Westen Admin

It is probably due to the system plugin ordering. Try changing the ordering of the plugins in question.
See: www.regularlabs.com/blog/242-plugin-order-is-important

1 year 4 months ago #71223

Shawn Scanlan's Avatar Shawn Scanlan

Hi Peter,
I've been down this particular road before and some reordering of plugins was the first thing I tried. No luck so far but I'll keep trying.
Thanks for the suggestion.
-Shawn

1 year 4 months ago #71261

Shawn Scanlan's Avatar Shawn Scanlan

Peter,
An update... No luck finding a plugin order that doesn't break certain pages as per the example above.
Sadly, I've had to disable Email Protector pending a resolution, should one become available.
Thanks,
-Shawn

1 year 4 months ago #71262

Peter van Westen's Avatar Peter van Westen Admin

Can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button to hide the confidential information.

1 year 4 months ago #71435

Shawn Scanlan's Avatar Shawn Scanlan

Sure Peter, Thanks.

You actually have Admin access. You helped with a Components Anywhere issue back in March.
So many customers, so little time! ;)

Confidential information:
(hidden)

Here's a good spot to see where the break happens when Email Protector (latest version) is enabled: sorrows.ca/ministries-groups/liturgical-ministries/lectors.html

Thanks again!
-Shawn

1 year 4 months ago #71436

Peter van Westen's Avatar Peter van Westen Admin

Have you already updated to the latest release from today?

1 year 4 months ago #71439

Shawn Scanlan's Avatar Shawn Scanlan

Sure have. See my last paragraph ;)
-S

1 year 4 months ago #71440

Peter van Westen's Avatar Peter van Westen Admin

Sorry, missed that.

I can't seem to get beyond the server login. Seems the credentials are not correct...

1 year 4 months ago #71441

Shawn Scanlan's Avatar Shawn Scanlan

Hmmm... strangeness abounds!

Confidential information:
(hidden)

Thanks,
-S

1 year 4 months ago #71442

Shawn Scanlan's Avatar Shawn Scanlan

Confidential information:
(hidden)

1 year 4 months ago #71443

Peter van Westen's Avatar Peter van Westen Admin

The server (first) login now passes, but the admin url redirects me to the main url with a "Please update to a modern browser" message.
Which is weird, as this happens in latest version of Chrome.
In Firefox I don't get the message, but it does redirect me to the frontend homepage.

So I still can't get into the administrator.

To be able to fully look into this issue, I would need (s)ftp access too.

1 year 4 months ago #71475

Shawn Scanlan's Avatar Shawn Scanlan

It is weird, Peter, but I have seen this before and have read similar reports.
Still on the hunt for a fix to this. A workaround seems to be: close and reopen Chrome.
Not sure why on earth you'd be having the FF issue you describe, except miskeying the obfuscated URL. Just tested on FF and login works for me.
-S

1 year 4 months ago #71476

Peter van Westen's Avatar Peter van Westen Admin

Nope, not woking after restarting Chrome, clearing cookies.
Now I get:

You are a spammer, hacker or an otherwise bad person. Your IP address, has been duly logged and automatically reported. Have a nice day!
Seems like AdminTools acting up.

1 year 4 months ago #71490

Shawn Scanlan's Avatar Shawn Scanlan

You're right. I find AT can be twitchy sometimes. Glad to have it installed though. Too many bad people out there :(

I have unblocked your IP and added it as an exception. I wish the whitelist feature wasn't an "all or nothing" kinda thing.

Confidential information:
(hidden)


Thanks for sticking with me on this.
-Shawn

1 year 4 months ago #71496

Peter van Westen's Avatar Peter van Westen Admin

Ok, well, that admin url is different to the first. the security string in the url is lower case. In your first post you placed it with a capital first letter.
So yes, I can get in the admin now.

But:

To be able to fully look into this issue, I would need (s)ftp access too.

1 year 4 months ago #71508

Shawn Scanlan's Avatar Shawn Scanlan

Oddly enough, and before I noticed my typo, I successfully logged in with your credentials using the URL with the miskeyed capital 'O'! :unsure:

Confidential information:
(hidden)

Thanks,
-Shawn

1 year 4 months ago #71511

Peter van Westen's Avatar Peter van Westen Admin

The issue is caused by RokCandy. It seems to not be able to deal with content containing inline <script> tags.
You will have to ask RocketTheme for support on this, or choose to not use Email Protector.

1 year 4 months ago #71514

Shawn Scanlan's Avatar Shawn Scanlan

RockCandy. As I expected. Thanks for trying.
-S