Content Templater

I can't get the dropdown to show in virtuemart

1 year 1 month ago #73181

Rikard Jespersen's Avatar Rikard Jespersen

Hi
I just started using the content templater to make life easy for my editors and it works like a charm for regular joomla content pages; but when I open a virtuemart article and try to use it I don't get a drop down showing my termplates. Instead nothing appears to happen while all the other content buttons appears to be working: Modules Anywhere, Widgetkit and Articles for example.

Is there perhaps a setting I have overlooked?

Thank you very much for making such great extensions!
Rikard

1 year 1 month ago #73182

Peter van Westen's Avatar Peter van Westen Admin

Probably VM is loading some javascript or styling causing conflicts.
Can you give me (super) admin access so I can take a look?
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

1 year 1 month ago #73188

Rikard Jespersen's Avatar Rikard Jespersen

Hi
Of course, please find the requested information here:

Confidential information:
(hidden)


Thank you very much for helping me out.
//Rikard

1 year 1 month ago #73193

Peter van Westen's Avatar Peter van Westen Admin

:)

I have no idea why it isn't showing. It is working fine on my test setup with VrtueMart.

I have changed the setting in the Content Templater configuration on your site to force it to open in a modal.
This does work on your VM views.

If you want me to look into this deeper, I would also need (s)ftp access to be able to do some deeper javascript testing.

1 year 1 month ago #73195

Rikard Jespersen's Avatar Rikard Jespersen

Hi Peter
Thank you very much for your help. The modal view works fine for me as I expect to have a list of many many snippets and the drop down wouldn't work anyway.

I'd love to give you an ftp user anyway just so for your own sake in case there is something interesting to be found but unfortunately I don't know how to setup a temporary user with the correct credentials :(. It's on my to do list to learn how to do it but I'm just not there yet. Still too much of a noob.

But thanks again for your awesome support and great extensions.
Rikard

1 year 1 month ago #73199

Peter van Westen's Avatar Peter van Westen Admin

Ok, my pleasure.

If you are still in the setup phase, then now is the time to consider not using VM.
It will bite you in the behind more than you bargained for.

There are other, better solutions, like HikaShop.

1 year 1 month ago #73200

Rikard Jespersen's Avatar Rikard Jespersen

uhm...I'm well into production so changing to another shop solution is not something I really can consider at the moment. I will take a look at HikaShop just for educational purposes however.

What in particular is it with VM that you think I should avoid?

Best regards,
Rikard

1 year 1 month ago #73205

Peter van Westen's Avatar Peter van Westen Admin

VM in general :)

1 year 1 month ago #73224

Rikard Jespersen's Avatar Rikard Jespersen

ouch! :p