Content Templater

Waarschuwing : Lege code is niet toegestaan

1 year 4 months ago #71254

Mandy's Avatar Mandy

Hallo Peter,

wij hebben een probleem met één vd websites waarop wij content templater gebruiken.
2 dagen geleden hebben we de site geupdate naar joomla 3.7 en hebben toen ook de contenttemplater geupdate naar de laatste versie : v7.1.4
nu krijgt de klant als deze een nieuw artikel wil toevoegen mbv de content template de foutmelding :" Waarschuwing : Lege code is niet toegestaan". Het artikel wordt ook niet opgeslagen.
ik heb toen onze php versie ook nog van 5.6 op 7.0 gezet maar dit heeft niet geholpen. (beide versies hebben mbstring functions enabled)

Inmiddels is er een backup van de site en database teruggezet en draaien we weer joomla 3.6.5 en Content Templater V7.12.

Kun jij aangeven wat er hier wellicht is mis gegaan.

mvrgr,
Klaas

1 year 4 months ago #71255

Peter van Westen's Avatar Peter van Westen Admin

Please keep the forum in English.

First off: try clearing the browser cookies and cache and the Joomla cache.

Try updating Content Templater first and see if it still works ok.
If so, update Joomla after that.

1 year 4 months ago #71256

Mandy's Avatar Mandy

1. cookies, cache browser & Joomla chache cleared
2. update to Content Templater 7.1.4.-pro
3. everything still works fine; new article or editing existing article possible
4. cookies, cache browser & Joomla chache cleared
5. update Joomla from 3.6.5 to 3.7.0
6. cookies, cache browser & Joomla chache cleared
7. new article or editing existing article not possible: " Waarschuwing : Lege code is niet toegestaan" (translation: Warning; Empty code is not allowed)

- new article or editing existing article still possible in back end, problem only occurs in front end

- tested in several browsers > makes no difference, problem still occurs

- updating PHP 5.6.28 to PHP 7 only results in more problems

- one of our other websites is set up similar to the website where the problem occurs, however this site has no Content Templater installed. This site could be updated to 3.7 and new article or editing article is still possible.

1 year 4 months ago #71257

Peter van Westen's Avatar Peter van Westen Admin

Are you able to create/save articles on the frontend when not using Content Templater on that website?
To fully test, you could temporarily disable the Content Templater plugins.

1 year 4 months ago #71258

Mandy's Avatar Mandy

OK, I disabled the Content Templater button & system plugins.
Cleared joomla & browser cache.
Went to front end and found that the problem still occurs.

So I figure Content Templater is not causing this problem.

After disabling some other extensions and testing again, I think I found the problem.
When I make Protostar the default template, the articles can be edited from the frontend again and the problem seems gone. So it must be the template that's causing the problem.

Sorry to have bothered you with this Peter, and thanks for your help!

1 year 4 months ago #71259

Peter van Westen's Avatar Peter van Westen Admin

This pretty much means that the issue is not connected to Content Templater.
Instead the issue seems down to your template (the article edit view) not being compatible with Joomla 3.7.
Best to ask the template developer for support on this.

1 year 4 months ago #71260

Mandy's Avatar Mandy

Yes I will do that, and thanks again :)