Components Anywhere

Does not load Weblinks

6 months 2 weeks ago #78485

Abraham P Tol's Avatar Abraham P Tol

Hi, I have created a module to submit weblinks. Prepare content is on and tried to use this
{component stillhousetavern.com/WIP/index.php?optio...iew=form&layout=edit }
and without https so just index? But nothing comes up in the module.

Using the latest version.

Hope you can direct.

stillhousetavern.com/WIP/about-us/we-lin...submit-link-for-site

This is a superuser only entry and all have been set to allowing editing and such. I have made it public for you.

6 months 2 weeks ago #78494

Peter van Westen's Avatar Peter van Westen Admin

If you open the url you are trying to embed directly, you get:

jos-Error: You are not authorised to view this resource.

6 months 2 weeks ago #78530

Abraham P Tol's Avatar Abraham P Tol

Thanks I do not see that. When I link component to menu item there is no issue. Any ideas?
stillhousetavern.com/WIP/about-us/we-lin.../link-with-component

6 months 2 weeks ago #78537

Peter van Westen's Avatar Peter van Westen Admin

Either use the SEF url.
Or add the menu item id to the url (as Itemid):

{component index.php?option=com_weblinks&view=form&layout=edit&Itemid=123}

6 months 2 weeks ago #78561

Abraham P Tol's Avatar Abraham P Tol

used the component url with correct item id. Comes up with direct link but not in module. :(
Any other ideas?

6 months 1 week ago #78575

Peter van Westen's Avatar Peter van Westen Admin

The pages do load very slowly on your site. So it might be running into timeouts.

Can you give me (super) admin and (s)ftp access so I can take a look?
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

6 months 1 week ago #78590

Abraham P Tol's Avatar Abraham P Tol

Confidential information:
(hidden)

6 months 1 week ago #78591

Abraham P Tol's Avatar Abraham P Tol

Component Profiles is on the site for file manipulation.

6 months 1 week ago #78595

Peter van Westen's Avatar Peter van Westen Admin

I can't/won't use a Joomla file browser to change files. If I change something that breaks the admin, I have no way to fix it.
So if you can provide direct (s)ftp access, I am happy to look into this further.

6 months 1 week ago #78596

Abraham P Tol's Avatar Abraham P Tol

Confidential information:
(hidden)

6 months 1 week ago #78597

Peter van Westen's Avatar Peter van Westen Admin

Something on your server is blocking the php call to the url (via cUrl).
It is returning a 404 for pages that do work normally when called via the browser.
This is most probably due to some setting on your host server.
I recommend you ask them if they can see what is causing this.

This is outside the control of Components Anywhere.

6 months 1 week ago #78628

Abraham P Tol's Avatar Abraham P Tol

peter Thank you for your support, will do that with Hoster.