CDN for Joomla!

Handling HTTPS

7 months 4 days ago #75685

Marketing Alpha's Avatar Marketing Alpha

How is http and https handled?
My https version is broken, with error "Mixed Content: The page at 'https://xxx' was loaded over HTTPS, but requested an insecure stylesheet ' xxx.css '. This request has been blocked; the content must be served over HTTPS."

I'm looking at the source code of my https site, and the cdn links are loading from http version.

Is there a setting I need to set?

Thanks,
Sky

7 months 4 days ago #75686

Peter van Westen's Avatar Peter van Westen Admin

Yes, check the SSL settings in the CDN for Joomla! system plugin.

7 months 4 days ago #75687

Marketing Alpha's Avatar Marketing Alpha

Thanks Peter, where can I find option?

7 months 4 days ago #75689

Peter van Westen's Avatar Peter van Westen Admin

Should work.

Can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

7 months 4 days ago #75691

Marketing Alpha's Avatar Marketing Alpha

ok

Confidential information:
(hidden)

7 months 4 days ago #75692

Marketing Alpha's Avatar Marketing Alpha

I turned off the CDNforJoomla plugin, and both http and https works now.

When you look into this, you can turn the plugin on and debug it.

7 months 4 days ago #75693

Peter van Westen's Avatar Peter van Westen Admin

The admin credentials do not work.

Also it is hard for me to debug stuff like this if I cannot dig into the code and see what is happening.

If you can reproduce this on an online environment to which I can get access, I am happy to look into this.