Cache Cleaner

Cache could not be cleaned - message

11 months 4 weeks ago #76215

Manfred Hübner's Avatar Manfred Hübner

Hi Peter,
I get this error message when using Cache cleaner on a website it recently worked. I changed the hardware so I guess it could have to do with permissions. I am working on IIS. But interestingly, I have other websites running on the same machine with similar settings where Cache cleaner works as usual.

Any idea where I can look further into?

Regards,
Manfred

Version notes: Joomla and your extension all latest versions, IIS on Windows 2012 R2 and MySQL 5.7.20 and PHP 7.0.25

11 months 4 weeks ago #76220

Peter van Westen's Avatar Peter van Westen Admin

Try emptying the cache folder manually and see if it works ok after that.

11 months 4 weeks ago #76227

Manfred Hübner's Avatar Manfred Hübner

Unfortunately not.

11 months 4 weeks ago #76231

Peter van Westen's Avatar Peter van Westen Admin

Can you see if there are any php errors in your error log after you try and clear the cache?

11 months 4 weeks ago #76234

Manfred Hübner's Avatar Manfred Hübner

Hello Peter, I can see that the php file has an response code 500, so an server error. But in the PHP log file, there is nothing in it. Do you know how I can force php to report more in the log? What I can also see, that cache cleaner works somewhat, the JCE cache will be emptied. Strange.

Regards,
Manfred

11 months 4 weeks ago #76235

Peter van Westen's Avatar Peter van Westen Admin

Can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button to hide the confidential information.

11 months 4 weeks ago #76236

Manfred Hübner's Avatar Manfred Hübner

Will do.

Confidential information:
(hidden)

11 months 3 weeks ago #76249

Peter van Westen's Avatar Peter van Westen Admin

The admin login credentials do not work.

11 months 3 weeks ago #76252

Manfred Hübner's Avatar Manfred Hübner

Sorry, the username was wrong ;-)

Confidential information:
(hidden)

11 months 3 weeks ago #76258

Peter van Westen's Avatar Peter van Westen Admin

Try triggering this url:

administrator/index.php?cleancache=1
As you can see it will give this error:
An error has occurred.
1143 SELECT command denied to user ''@'localhost' for column 'storage_path' in table '#__docman_documents'
So looks like DocMan is trying to do something that causes issues.

11 months 3 weeks ago #76263

Manfred Hübner's Avatar Manfred Hübner

Hi Peter,
thanks for your help. This was an important hint. I have reinstalled Docman and it now works :-)

Thanks a lot!

Regards
Manfred

11 months 3 weeks ago #76264

Peter van Westen's Avatar Peter van Westen Admin

Great :)