Bug Reports

URGENT! Update totally crashed the whole site! Cannot access /administrator area either!

7 months 1 day ago #88186

Jasmin's Avatar Jasmin

I had the latest joomla v3.9.11. Running a dev platform on Win10 /Ampps.

I tried your free plugin and I believe I only had the Sourcerer plugin active, everything working, incl sourcerer.

The update of it made the whole Windows 10 freeze. No BSOD. Had to hard reset computer. Very rare.

Now I can't even access site admin area, so this is a pretty urgent situation.

Checked directories and \components\com_regularlabsmanager was 0b large = empty.

Please advice ASAP!

( ! ) Fatal error: Class 'RegularLabs\Plugin\System\Sourcerer\Plugin' not found in C:\Program Files (x86)\Ampps\www\drfun\plugins\system\sourcerer\sourcerer.php on line 34
Call Stack
# Time Memory Function Location
1 0.0017 369480 {main}( ) ...\index.php:0
2 0.2411 4242312 Joomla\CMS\Application\AdministratorApplication->execute( ) ...\index.php:51
3 0.2411 4242312 Joomla\CMS\Application\AdministratorApplication->doExecute( ) ...\CMSApplication.php:196
4 0.2412 4242584 Joomla\CMS\Application\AdministratorApplication->initialiseApp( ) ...\AdministratorApplication.php:123
5 0.3062 4772824 Joomla\CMS\Application\AdministratorApplication->initialiseApp( ) ...\AdministratorApplication.php:301
6 0.3780 5473472 Joomla\CMS\Plugin\PluginHelper::importPlugin( ) ...\CMSApplication.php:625
7 0.3899 5518600 Joomla\CMS\Plugin\PluginHelper::import( ) ...\PluginHelper.php:182
8 0.3910 5533136 require_once( 'C:\Program Files (x86)\Ampps\www\drfun\plugins\system\sourcerer\sourcerer.php' ) ...\PluginHelper.php:253

7 months 1 day ago #88187

Peter van Westen's Avatar Peter van Westen Admin

Try deleting this folder and reinstall Sourcerer:

/plugins/system/sourcerer

7 months 17 hours ago #88206

Jasmin's Avatar Jasmin

Following your instruction, parts of the Joomla system became visible, but with new errors, and I can still not login, even though the top bar appeared but with no admin menu. Before was only php errors, now it's some joomla with errors, both at frontpage and admin.

---

An error has occurred while processing your request.
You may not be able to visit this page because of:

an out-of-date bookmark/favourite
a mistyped address
a search engine that has an out-of-date listing for this site
you have no access to this page

If difficulties persist, please contact the System Administrator of this site and report the error below.
0 Class 'RegularLabs\Plugin\System\RegularLabs\DownloadKey' not found (this same message at /administrator/)

What to do to regain access to my site?

7 months 17 hours ago #88207

Peter van Westen's Avatar Peter van Westen Admin

Well, looks like a lot went haywire during installation.

See if deleting these folders makes your website work again:

/libraries/regularlabs
/plugins/system/regularlabs

Then install the Regular Labs that has the latest release date.

If your website keeps giving issues, I recommend you place back your last working backup (the one you made before updating stuff).

7 months 16 hours ago #88209

Jasmin's Avatar Jasmin

Getting there slowly...

Regained access to admin and RegularLabs Extension Manager, but with sourcerer lacking the green install button. Trying to delete it seems to fail, same result. Tried reinstalling everything in many ways. Sourcerer is still a problem.

Feedback
Also helped better to regain less errors to delete:
\plugins\system\advancedmodules

Checking the left square and installing Sourcerer from top buttons (since the green install is gone), gives this fail:
(Tried also to del /plugins/system/sourcerer before)

Finished
Copy failed: C:\Program Files (x86)\Ampps\www\joomla_test\tmp\install_5d6d1f52450a9\packages\plg_editors-xtd_sourcerer\fields.xml to C:\Program Files (x86)\Ampps\www\site\plugins\editors-xtd\sourcerer\fields.xml
JInstaller: :Install: Failed to copy file C:\Program Files (x86)\Ampps\www\joomla_test\tmp\install_5d6d1f52450a9\packages\plg_editors-xtd_sourcerer\fields.xml to C:\Program Files (x86)\Ampps\www\site\plugins\editors-xtd\sourcerer\fields.xml
Plugin Install: Could not copy files from the source.

Also, clicking to enter the plugin from admin gives this error...

An error has occurred.
500 The file sourcerer.xml could not be found.

It's getting there. What to do?

In general, I believe you're a skilled programmer, so how can you prevent that some errors in your plugins takes whole sites down & what could you do so the fix and repair would be automatic or more simple?

I'm thinking a complete UNINSTALL SCRIPT that removes ALL traces of RegularLabs, incl files and DB entries, could help get us restarted successfully. That shouldn't be to hard. Is it a good solution? You'll think of something bright, I am sure.

Before that future solution and improvement, what do you think I can do now, to not restart the development from an older backup?

I believe it's getting there. Just some more to delete, to make it work?

7 months 16 hours ago #88210

Peter van Westen's Avatar Peter van Westen Admin

These are not errors in my extensions.
This is caused by issues on your setup, causing files to not get written. So files are not there (or empty). The same thing will happen with other extensions, or Joomla.
So you should look into why files don't get written. Probably an issue with file/folder permissions.

Again, this is an issue with your setup. So not something I can solve for you.

6 months 4 weeks ago #88228

Jasmin's Avatar Jasmin

I noticed you've made an update for Sourcerer today, and it was suddenly upgradable.

Everything now works again.

Thanks for the upgrade and fixes.