Articles Anywhere

Update of Articles Anywhere consume all server resources

3 months 2 weeks ago #89765

Peter van Westen's Avatar Peter van Westen Admin

Can you narrow down which {articles} tag is causing this?
And can you reproduce this on a page where only that tag is running? So no other modules with {article} tags around it...

3 months 2 weeks ago #89766

Peter van Westen's Avatar Peter van Westen Admin

Ok, think I found the issue.

Please try the latest development version from:
www.regularlabs.com/development-releases

3 months 2 weeks ago #89767

Sukinoz's Avatar Sukinoz

Peter van Westen wrote:

Ok, think I found the issue.

Please try the latest development version from:
www.regularlabs.com/development-releases

Thanks Peter,

Installed, but I don' t see any change in the server resources consumes.

(I have asked to the hosting support also to check it)

3 months 2 weeks ago #89768

Peter van Westen's Avatar Peter van Westen Admin

If you still have the issue:

Can you narrow down which {articles} tag is causing this?
And can you reproduce this on a page where only that tag is running? So no other modules with {article} tags around it...

3 months 2 weeks ago #89780

Andrea Malalana's Avatar Andrea Malalana Moderator

Any update @Sukinoz?

3 months 2 weeks ago #89783

Sukinoz's Avatar Sukinoz

No yet. I had no time.sorry

3 months 1 week ago #89847

Sukinoz's Avatar Sukinoz

Sukinoz wrote:

Peter van Westen wrote:
Ok, think I found the issue.

Please try the latest development version from:
www.regularlabs.com/development-releases

Thanks Peter,

Installed, but I don' t see any change in the server resources consumes.

(I have asked to the hosting support also to check it)

Hello,

The development version solved the huge querie. Thanks.

Now we are not sure what is consuming the server resources. It seems Articles Anywhere increases resource consumption, but perhaps as expected.

3 months 1 week ago #89848

Peter van Westen's Avatar Peter van Westen Admin

Well, like any extension (except What? Nothing!), Articles Anywhere has to do something. So it will use at least some resources. But this should be nowhere near as noticeable as you say.

Can you see if you can isolate the issue. See if you can reproduce it on a clean setup without any other 3rd party extensions running.
I have a feeling that one of your other extensions is causing some looping issue somewhere, triggering Articles Anywhere over and over again.

3 months 6 days ago #89900

Sukinoz's Avatar Sukinoz

Peter van Westen wrote:

Well, like any extension (except What? Nothing!), Articles Anywhere has to do something. So it will use at least some resources. But this should be nowhere near as noticeable as you say.

Can you see if you can isolate the issue. See if you can reproduce it on a clean setup without any other 3rd party extensions running.
I have a feeling that one of your other extensions is causing some looping issue somewhere, triggering Articles Anywhere over and over again.

Just to update the information about this problem:

The problem is very difficult to measure. It is simply an increase in CPU consumption. Normally the website consumes 5-10%, and with this problem it goes up to 15-20%, approximately. This small increase means that when there are many visits the limits of the server are reached.
I do not have SSH access to the server, nor knowledge of Apache, so the only way I have to measure these variations in consumption by doing F5 in the Cpanel control panel, which is very approximate.
Conclusion, I have migrated the web to another server where it seems that something better is going and so it stays for now.

Thanks again.

3 months 6 days ago #89902

Peter van Westen's Avatar Peter van Westen Admin

Ok 👍