Advanced Module Manager

Exclude by Menu Item broken?

10 months 1 week ago #77849

Chris Chase's Avatar Chris Chase

Hello All,

I logged into one of our sites this morning since I saw a module appearing on our homepage that shouldn't be there. I was surprised to discover that the entire menu tree was gone and had been replaced by this jumble of text. Can anyone explain to me whats going on here and what I can do to correct this. It appears to be happening sitewide on all modules.

drive.google.com/a/directive.com/uc?id=1...w0SLpxKvVoAAsn6h_wTf

10 months 1 week ago #77850

Peter van Westen's Avatar Peter van Westen Admin

Make sure your Joomla setup is uptodate and that the Joomla core Ajax extension is installed and enabled.
Take a look at the Extensions > Manage > Discover page to see if stuff is not correctly installed.

10 months 1 week ago #77851

Chris Chase's Avatar Chris Chase

Hello Peter,

Thanks for your quick reply, unfortunately I don't see anything listed for Ajax and we are on Joomla 3.8.3. Here is a screen shot of what appears in the discovery screen: drive.google.com/a/directive.com/uc?id=1...FGS6Tv8r01CUHM0zucau

10 months 1 week ago #77853

Peter van Westen's Avatar Peter van Westen Admin

Can you give me (super) admin access so I can take a look?
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

10 months 1 week ago #77857

Chris Chase's Avatar Chris Chase

Sure no problem, I created an account for you. Please use the information below

Confidential information:
(hidden)

10 months 1 week ago #77860

Peter van Westen's Avatar Peter van Westen Admin

It's all working fine here.
Make sure you clear your browsers cache and try again...

10 months 1 week ago #77865

Chris Chase's Avatar Chris Chase

It does appear to be working on some modules now that you mention it, the module in question is: drive.google.com/a/directive.com/uc?id=1...O_suiJYbOl5MU5ewcTxz

its titled "Live Chat", would you mind taking a quick look at that one for me.

10 months 1 week ago #77867

Chris Chase's Avatar Chris Chase

Its just a custom HTML module so it seems strange it would be different than any of the others.

10 months 1 week ago #77875

Peter van Westen's Avatar Peter van Westen Admin

I emptied that field and saved it. It is working now.
So you only want to exclude the module from your homepage? Then you shouldn't be using the Menu Item assignment at all. Just exclude from Home Page (assignment) like it is now.