Advanced Module Manager

Hikashop filter problem

3 months 2 weeks ago #77751

Patrick Gaulin's Avatar Patrick Gaulin

Hi,

I have an issue with the way the module is displayed into Hikashop.

I have configurated the assignment to have the module visible into a Hikashop category and the child elements (products)


The module is correctly displayed on the category page but not the products page. Any idea what I'm missing? Thanks,

More info:

I have the lasted version of Advanced Module Manager installed.


The page of the category:

Confidential information:
(hidden)


The page of a product:
Confidential information:
(hidden)


The module setups (nothing else is checked into Advanced Module Manager):
www.dev.cochercapella.ca/tmp/setup-ama.png

3 months 2 weeks ago #77752

Peter van Westen's Avatar Peter van Westen Admin

and the child elements (products)
The 'Child items' option under the HikaShop category selection does not refer to products. It refers to child categories of the selected categories in the selection box.

To make it also show on products, you need to select the Products page type.

3 months 2 weeks ago #77759

Patrick Gaulin's Avatar Patrick Gaulin

Thank you for your answer and thank you very much for your excellent work. You save me so much time in my day to day work whit your extensions.

Just to be 100% sure, I will have to manually add the module to each new product in that category? Is there a way to make it automatic?

3 months 2 weeks ago #77760

Patrick Gaulin's Avatar Patrick Gaulin

I tried to add "page type: product" and it doesn't work.

I choose "Matching Method: Any" and the module disappeared everywhere.

Any idea?

3 months 2 weeks ago #77763

Peter van Westen's Avatar Peter van Westen Admin

No, you need to check the page type 'product ' under your category selection.

3 months 2 weeks ago #77764

Patrick Gaulin's Avatar Patrick Gaulin

It is already checked but the module doesn't appear on the product page. (see image bellow)

www.dev.cochercapella.ca/tmp/setup-ama.png

3 months 2 weeks ago #77767

Peter van Westen's Avatar Peter van Westen Admin

Can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

3 months 2 weeks ago #77769

Patrick Gaulin's Avatar Patrick Gaulin

Thanks! There is the information needed. Please let me know what you will change. If you need anything else, just ask me.

Confidential information:
(hidden)

3 months 2 weeks ago #77770

Peter van Westen's Avatar Peter van Westen Admin

Please try the latest development version from:
www.regularlabs.com/development-releases

3 months 2 weeks ago #77783

Patrick Gaulin's Avatar Patrick Gaulin

Thanks! It works perfectly.

3 months 2 weeks ago #77784

Peter van Westen's Avatar Peter van Westen Admin

Ok, great :)
The fix will be included in the next release.

3 months 2 weeks ago #77785

Patrick Gaulin's Avatar Patrick Gaulin

I have another issue.

The module doesn't appear on the English side of the website. Only in French.

Some info:
- Falang translation is ok
- I selected both languages onto Advanced Module Manager Language options.
- When I turn off the Hikashop filter of Advanced Module Manager, the display is ok in both languages.

Any idea?

Confidential information:
(hidden)

3 months 2 weeks ago #77786

Peter van Westen's Avatar Peter van Westen Admin

Advanced Module Manager asks HikaShop to figure out what category is active on the page.
For the English page it returns category 2 instead of 22.
Not sure what I can do about that.

Also, make sure you update Joomla and your extensions first.