Advanced Module Manager

Update changes template

2 months 1 week ago #76754

Simon Jones's Avatar Simon Jones

Hi, a site I manage for a customer uses AMM for press releases generated from rss feeds. Like on this page here:

www.thebridge-group.com/law-firms/nossaman-llp.html

you'll see on the right of the page the news feed is displayed correctly and only on this page for this firm, some of the others have news feeds too but are specific to that firm, however after I updated advanced module manager I checked the site and it was displaying the news feed on every page and the same one for all firms.

I restored the site from backup while I try to work out what broke the template after the update.

Many thanks for any help you can provide.

2 months 1 week ago #76755

Peter van Westen's Avatar Peter van Westen Admin

What kind of assignment(s) have you set on the effected module?

2 months 1 week ago #76756

Simon Jones's Avatar Simon Jones

Hi Peter, I have the following;

Same as other module - No
Matching Method - ALL
Show Assignments - ALL

Everything else is set as Ignore with the exception "Items" which is set to include a selection with a value set to 10.

Simon

2 months 1 week ago #76757

Peter van Westen's Avatar Peter van Westen Admin

What "items" do you mean? Articles?

Can you give me (super) admin and (s)ftp access so I can take a look?
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

2 months 1 week ago #76758

Simon Jones's Avatar Simon Jones

Hi Peter,

Confidential information:
(hidden)

I will need you IP address in order to provide sftp access.

2 months 1 week ago #76759

Peter van Westen's Avatar Peter van Westen Admin

Can you reproduce the issue on a setup that is uptodate on which I can get access and see the issue?
So a setup with the latest version of Joomla and Advanced Module Manager and any other extension that is currently outdated.

Also, go to /administrator/index.php?option=com_installer&view=discover and make sure that you don't have half-installed extensions there.
The Joomla core 'Ajax Interface' extension is important for Advanced Module Manager too (which is currently not correctly installed on your setup).

2 months 1 week ago #76760

Simon Jones's Avatar Simon Jones

I could restore to a test environment and do the updates on there for testing, I'll take a backup and then set that up and get back to you. Noted on the Ajax interface, I'll add this to the test setup too.

2 months 1 week ago #76776

Simon Jones's Avatar Simon Jones

Hi Peter,

ok I restored the site to a different cpanel host and changed the url to dev.thebridge-group.com, added the Ajax Interface and updated to the AMM 7.4.1 - checked the site and all is good, it didn't change the home page or mess with the press releases at all, however I can't get the updated news feed to show up for irwin mitchell - this is in extensions > modules > press release (irwin mitchell)

your reglabs login will still work on the dev site. I'm not sure why it messed up on the production site unless it is something to do with the Ajax Interface?

2 months 1 week ago #76777

Peter van Westen's Avatar Peter van Westen Admin

What is the url of the dev site, the url of the page I can see the issue on (irwin mitchell), and the id of the module in question.

2 months 1 week ago #76779

Simon Jones's Avatar Simon Jones

2 months 1 week ago #76781

Peter van Westen's Avatar Peter van Westen Admin

That is because your assignment is incorrect. You assigned it to K2 item 10, which is not the 'irwin mitchell' item. That is ID 22.

2 months 1 week ago #76783

Simon Jones's Avatar Simon Jones

AAAHH!! You have no idea how long I've spent trying to figure out what was wrong with this feed! Thank you so much Peter!