Add to Menu

Possible bug in alias generation

3 years 5 months ago #39011

AnyWay's Avatar AnyWay

Hello,
when I add an item with Add-to-Menu, if I don't specify the alias, I get the current date, instead of joomla default behavior. I'm not sure if it's bug, or your choice, anyway I've reported it. [Joomla 3.3.6]

3 years 5 months ago #39016

Peter van Westen's Avatar Peter van Westen Admin

That means there is already another item with that alias. It will then give the date as alias. That is also Joomla default behaviour.

3 years 5 months ago #39021

AnyWay's Avatar AnyWay

Oh, nice to know, thank you. I will try again!

3 years 5 months ago #39061

AnyWay's Avatar AnyWay

I've tried again, it happens even if the alias does not exists, infact, removing with Joomla the "date alias" and saving again leaving blank, places the right alias.
How to reproduce it:
1) Click to add to menu
2) Change the default title
3) Remove the alias
4) Save
5) A date is assigned

3 years 5 months ago #39070

Peter van Westen's Avatar Peter van Westen Admin

Ok, found the problem.
I have sent you a new version to test out. Let me know if that fixes the issue.

3 years 5 months ago #39073

AnyWay's Avatar AnyWay

I confirm you that the new version fixed the problem. Thank you.

3 years 5 months ago #39075

Peter van Westen's Avatar Peter van Westen Admin

Great. Thank you for notifying and testing!
The fix will be included in the next release.

PS: Please post a rating for Add to Menu at the Joomla! Extensions Directory extensions.joomla.org/extension/add-to-menu